Trouble restarting step in workflow

I’m trying to use the reana-client restart tool to re-run the final step of my workflow after making some updates, and having some trouble. The final step (as encoded in the yadage workflow.yml) is called interpretation_stage:

- name: interpretation_stage
  dependencies: [make_dict_stage, skimming_stage_mc16a, init]
    scheduler_type: singlestep-stage
      input_dict: {step: make_dict_stage, output: python_dict}
      monojet_conf: {step: skimming_stage_mc16a, output: monojet_conf}
      makeLimitScript: {step: init, output: makeLimitScript}
      outputdir: '{workdir}/Interpretation_output'
    step: {$ref: steps.yml#/interpretation_stage}

Here is my reana.yaml:

version: 0.6.0
    run_num: '311454'
    DAOD_mc16a: 'root://'
    DAOD_mc16d: 'root://'
    DAOD_mc16e: 'root://'
    #xSec_dir: 'root://'
    #antiSF_dir: 'root://'
    makeLimitScript: 'root://'

  type: yadage
  file: workflow.yml
    - interpretation_stage/Interpretation_output/LimitDir/asymptotics/limit_CL95.txt

I tried restarting the step from the workflow named monojet.26 (see attached monojet #26) as follows:

reana-client restart -w monojet.26 -o FROM=interpretation_stage

This failed without logs (see attached monojet #26.1)

I also tried re-starting from the previous step, make_dict_stage, and got the same result (see attached monojet #26.2).

I’m not sure if this is a bug or user error. If it looks like a bug, let me know and I can repost it as an issue on the github page repo.